TOP 10 POWER Bl INTERVIEW
QUESTIONS

1. WHAT IS POWER BL AND WHAT ARE ITS KEY FEATURES?

Power Bl is a business intelligence platform that allows you to connect to various data sources,
transform and analyze data, and create interactive reports and dashboards. Some of its key
features are:

- Range of attractive visualizations: Power Bl offers a wide range of detailed and
attractive visualizations that can help you present your data in an engaging way. You can also
create custom visualizations with R and Python libraries

- Data compression and aggregation: Power Bl can compress and aggregate large datasets to
improve performance and speed up queries. You can analyze datasets containing over 100
million rows with Power BI

- Integration with other Microsoft products: Power Bl can integrate seamlessly with other
Microsoft products such as Excel, SharePoint, Teams, Azure, and more. You can easily import
data from Excel, analyze it in Power Bl, and share it with your team.

- Data security and governance: Power Bl ensures your data is safe with industry-leading data
security features such as sensitivity labeling, end-to-end encryption, real-time access
monitoring, and row-level security. You can also apply your own encryption keys with bring
your own key (BYOK) feature.

2. HOW CAN | IMPORT DATA INTO POWER BI?

There are different ways to import data into Power BI, depending on the type and source of your
data. Some of the common methods are:

- Import Excel workbooks: You can import Excel workbooks that contain Power Query queries
and Power Pivot models into Power BI Desktop. To do this, select File > Import > Power Query,
Power Pivot, Power View from Power Bl Desktop, and choose an Excel workbook to import.

- Connect to online services: You can connect to various online services that you use,

such as Salesforce, Google Analytics, Facebook, etc., and import data from them. To do this,
select Get data > Services from the Power Bl service, and choose an app from the list. You might
need to sign in to your account for the service.

- Connect to databases: You can connect to various databases, such as SQL Server, Oracle,
MySQL, etc., and import data from them. To do this, select Get data > Databases from the
Power BI service, and choose a database from the list. You might need to provide connection
details and credentials.

- Enter data directly: You can enter data directly into Power BI Desktop in the form of a new
table. To do this, select Enter data from the Home ribbon in Power Bl Desktop, and enter or
paste your data into the table editor.



3. WHAT ARE THE DIFFERENT TYPES OF DATA CONNECTIONS SUPPORTED BY POWER BI?

According to web search results, there are three main types of data connections in Power BI:
import, DirectQuery, and live connection'. Here is a brief overview of each type:

- Import: This type copies the data from the data source into the Power Bl dataset. The imported
data can be refreshed manually or on a schedule. This type allows for fast performance and rich
data modeling capabilities, but it also consumes more memory and
disk space and may not reflect the latest changes in the data source.

- DirectQuery: This type dynamically requests data from the data source using queries
generated by Power BI. The data is not stored in the Power BI dataset, but it reflects the current
state of the data source. This type allows for near real-time data analysis and supports large
volumes of data, but it also depends on the performance and availability of

the data source and has some limitations on data modeling and transformations.

- Live connection: This type connects a Power Bl report to an existing Power Bl dataset, Azure
Analysis Services database, or SQL Server Analysis Services database. The data is not stored in
the Power BI dataset, but it relies on the existing data model and calculations. This type allows
for reusing existing datasets and creating consistent reports across the organization, but it also
restricts the ability to modify or extend the data model and requires a gateway for on-premises
data sources.

4. HOW DO | CREATE VISUALIZATIONS IN POWER BI?

To create visualizations in Power Bl, you need to have a report with a dataset. You can create a
report by importing data from various sources, such as files, databases, online services, etc., or
by connecting to an existing dataset in the Power Bl service.

Once you have a report, you can add visualizations to it by selecting fields from the Fields pane.
Power BI will automatically create a default visualization based on the type and number of
fields you select. You can change the type of visualization by selecting a different icon from the
Visualizations pane. You can also customize the appearance and properties of your
visualizations by using the options in the Format tab.

Power BI offers a wide range of visualization types, such as bar charts, line charts, pie charts,
maps, gauges, cards, etc. You can also create custom visuals using the Power BI visuals SDK or
download visuals from the Microsoft AppSource. Some of the visualization types are also
powered by artificial intelligence (Al), such as the decomposition tree and the key influencers
chart.



5. WHAT IS A MEASURE IN POWERBI, AND HOW DO | CREATEONE?

A measure in Power Bl is a calculation that you create using Data Analysis Expressions (DAX)
to analyze your data. A measure can be based on one or more columns from one or more tables
in your dataset. A measure can also use other measures as inputs. A measure is always
calculated in the context of the report or dashboard that you are viewing, and it changes
dynamically as you interact with your visuals.

To create a measure in Power Bl Desktop, you can use one of the following methods:

- Automatic measures: Power Bl Desktop automatically creates a measure for you when you
drag a numeric field onto a visualization. The default aggregation for the measure is Sum, but
you can change it to other types, such as Average, Count, Min, Max, etc., by using the drop-
down menu in the Values area of the Visualizations pane.

- Quick measures: Power Bl Desktop provides a collection of ready-made measures that you can
select from dialog boxes. Quick measures cover some of the most common and powerful
calculations, such as running total, percentage of total, year-over-year change, etc. To create a
quick measure, right-click or select the ellipsis (...) next to any item in the Fields pane, and
choose New quick measure from the menu that appears.

- Custom measures: You can create your own measures by writing DAX formulas in Power Bl
Desktop. To create a custom measure, select New Measure from the Calculations group in the
Home tab of the ribbon. A formula bar will appear where you can enter your DAX expression
and name your measure.

6. HOW CAN | FILTER AND SORT DATA IN POWER BI?

You can filter and sort data in Power BI to display only the relevant information and arrange it
in a specific order. There are different types of filters and sorting options that you can apply
to your data, depending on the level and scope of your report.

- Filtering data: You can filter data at the visual level, the page level, or the report level. You can
also use slicers and drillthrough filters to interactively filter data on your report. Filters

are applied to data after it is retrieved from the data source, and they affect how the data is
displayed in your visuals.

- Sorting data: You can sort data by one or more fields in a visual, such as a table or a

chart. You can also add interactive sort buttons to enable users to change the sort order of rows
or columns. Sorting data affects how the data is ordered in your visuals, but it does not affect
the calculations or aggregations®.

To filter or sort data in Power BI Desktop, you can use the filter pane on the right side of the
report canvas. You can select a visual and choose a field to filter or sort by. You can also use the
drop-down menus or icons on the visual headers to access filtering and sorting options'2.



7. WHAT ARE SLICERS AND HOW CAN | USE THEM IN POWERBI?

Slicers are a type of visual that filters the other visuals on a report page based on your selection.
You can use slicers to display commonly used or important filters on the report canvas for easier
access. You can also see the current filtered state without having to open a drop-down list’.

To use slicers in Power Bl Desktop, you can select the Slicer icon in the Visualizations pane and
drag a field from the Fields pane onto the slicer. You can then resize and format the
slicer as you like. You can also control which visuals are affected by the slicer by using the Edit

interactions option in the Format tab’.

Power BI Desktop supports various types of slicers, such as:

- Basic slicers: These are slicers that display a list of values with checkboxes. You can select one

or more values to filter the data.

- Numeric range slicers: These are slicers that display a range of numeric values with handles.

You can drag the handles to adjust the range to filter the data.

- Relative date slicers: These are slicers that display a range of dates relative to the current date.

You can select a time unit and a number of units to filter the data.

- Relative time slicers: These are slicers that display a range of times relative to the current time.

You can select a time unit and a number of units to filter the data.

- Hierarchy slicers: These are slicers that display a hierarchy of fields with expand and collapse

buttons. You can drill down or up to filter the data at different levels.

- Image and shape slicers: These are slicers that display images or shapes instead of text values.

You can select one or more images or shapes to filter the data.
8. HOW CAN | CREATE CALCULATED COLUMNS AND TABLES IN POWER BI?

Calculated columns and tables are ways to create new data based on Data Analysis Expressions
(DAX) formulas in Power Bl Desktop. You can use them to extend your data model with
additional fields or tables that are not available in your data source.

- Calculated columns: A calculated column is a column that you add to an existing table in your
data model. The values in the column are calculated row by row using a DAX formula that you
define. For example, you can create a calculated column that combines the first and last name of
a customer into a full name column

- Calculated tables: A calculated table is a table that you create as a new table in your data
model. The rows and columns in the table are calculated using a DAX formula that you define.
For example, you can create a calculated table that unions or joins two existing

tables into one table?.

To create a calculated column or table in Power BI Desktop, you can use the New Column or
New Table option in the Home tab of the ribbon. You can then enter your DAX formula in the
formula bar and name your column or table. You can also use the Modeling tab of the ribbon to
format and categorize your column or table.



9. WHAT ARE THE DIFFERENT TYPES OF VISUALIZATIONS AVAILABLE IN POWERBI?

Visualizations are graphical representations of your data that help you to explore, analyze, and
communicate insights. Power Bl offers a variety of visualization types that you can use in your
reports and dashboards. Some of the common visualization types are:

- Column and bar charts: These are charts that display data using vertical or horizontal bars.
They are useful for comparing values across categories or showing trends over time.

- Line charts: These are charts that display data using lines that connect data points. They are
useful for showing changes or trends over time or across categories.

- Pie and donut charts: These are charts that display data using circular segments. They are
useful for showing proportions or percentages of a whole.

- Maps: These are visualizations that display data using geographical locations. They are useful
for showing spatial patterns or relationships.

- Matrix and table: These are visualizations that display data using rows and columns. They are
useful for showing detailed or tabular data.

- Cards and KPIs: These are visualizations that display single values or metrics. They are useful
for showing key facts or indicators.

- Slicers: These are visualizations that allow you to filter other visuals on the report page based
on your selection. They are useful for displaying commonly used or important filters
on the report canvas.

- Decomposition tree: This is an Al visualization that allows you to explore data across multiple
dimensions. It automatically aggregates data and enables drilling down into your dimensions in
any order.

- Key influencers: This is an Al visualization that allows you to analyze what factors influence a
key metric. It shows the top factors that have the most positive or negative
impact on the metric.

- Smart narrative: This is a visualization that generates natural language summaries of your data
based on your visuals. It helps you to create dynamic and interactive narratives for your reports.



10. HOW CAN | CREATE RELATIONSHIPS BETWEEN MULTIPLE TABLES IN POWER BI?

Relationships are connections between two or more tables in your data model that enable you
to analyze data from multiple sources together. Relationships are based on a common column
that exists in both tables, such as a product ID or a customer ID. Relationships allow you to
create accurate calculations and display correct information in your reports.

To create relationships between tables in Power Bl Desktop, you can use one of the
following methods:

- Autodetect during load: Power Bl Desktop automatically detects and creates

relationships for you when you import data from multiple tables at the same time. It looks at the
column names and values to determine if there are any potential matches. If there are, it creates
the relationships and sets the options for cardinality, cross filter direction, and active status.

- Autodetect after load: You can also use the autodetect feature after you have loaded data from
multiple tables. On the Modeling tab, select Manage relationships > Autodetect. Power BI
Desktop will scan your tables and create any relationships it finds.

- Manual creation: You can also create relationships manually by using the Manage
relationships dialog box. On the Modeling tab, select Manage relationships > New. In the
Create relationship dialog box, select the two tables and the columns you want to use for the
relationship. You can also configure the options for cardinality, cross filter direction, and

active status.

You can view and edit your relationships in the Relationship view of Power Bl Desktop. You
can also use Data Analysis Expressions (DAX) functions to modify or override the default
behavior of relationships in your calculations.



